Download

How to import from world machine to UE4

Hello,

I’ve searched the internet for tutorials about this but i can’t seem to find my mistake.I keep getting spiky terrain when i import my heightmap to UE4
What i did is :
1.I first set my resolution.
http://tinypic.com/view.php?pic=mn20xz&s=8#.VIgOLnvPUTU
2.Determine the height of the terrain.
http://tinypic.com/view.php?pic=jt8lch&s=8#.VIgL0XvPUTU
3.I build the terrain and then export the heightmap
http://tinypic.com/view.php?pic=2q9l6c9&s=8#.VIgMC3vPUTU
4.Then i import my file to UE4.
http://tinypic.com/view.php?pic=r078yb&s=8#.VIgNinvPUTU

And this is my result : http://tinypic.com/view.php?pic=e9ut74&s=8#.VIgQ_HvPUTV

Any help is really appreciated :slight_smile:

I dont have much experience with world machine, but in terresculptor you always have to decrease the Z scale value in the UE4 properties after you have imported your heightmap. :slight_smile:

Otherwise compare your workflow with the one showed in this video: https://www.youtube.com/watch?v=K9WTKK9f1b8

I’ve tried that but how do you know how much to decrease and if you do decrease it it kind of looses it shape .I have also seen this tutorial and i did what he did and still the same result.

In UDK the Z axis was 3 times higher, but I dont know how it is in the UE4 :wink: -> but when it looses it’s shape, the Z value isnt the problem. Could you probably post a picture of your heightmap?

But here is a thread about the Z axis “problem”: Why are my imported landscapes being skewed along the Z axis? - UE4 AnswerHub

In WM on the Project Settings page, under the “General Setup” tab, set the “Maximum Elevation” to 5120 meters. Then when you import the landscape into UE4, setting the Z scale to 1000 will make the landscape 5120 meters exactly.

Some how changing the elevetion and the z value isn’t fixing my problem :/… Here is an image of how the terrain should look like http://tinypic.com/view.php?pic=14xdtu0&s=8#.VInFqXvPUTU

What does it look like in UE4?

The same as i posted before similar to this http://tinypic.com/view.php?pic=e9ut74&s=8#.VIgQ_HvPUTV

What format are you using for the heightmap when you import it in to Unreal Engine?

Can you share that file, maybe we can try to import it on our side on a fresh project and try to help debug the issue for you. 8-}

This tutorial is about Tiled landscape for world composition, but it may help you with correct settings for export

I am using format raw16.Sure here is the file : http://www.filedropper.com/testmap3. I will try to tile build it and i’ll tell you if that worked for me.

I think this is probably the trick … after reading that tutorial … Change the Z scale. Times the world height used from World Machine by 0.1953125 and enter that number in Z scale.

this tutorial zeorb worked for me :slight_smile: i guess i have to export as tile .one more question tho how can i build my light for this terrain tho it doesn’t render the light. i don’t think it’s changing the z scale since i imported my terrain now without tiles and without this tut and it kinda worked the only thing i have the same is the resolution so im thinking that was the problem

Just thought I’d mention that if you times 5120 by 0.1953125 you end up with 1000. Which will give you a landscape which can reach 2.5km above and below 0 on the z axis. Which is just under the maximum size. 1000 is a nice round number and didnt require any math to figure out, 1 meter in World Machine is 1 meter in UE4.