How to import a changed skeletal mesh back into UE4?

Export a skeletal mesh from UE4 into maya → Change it → Re import changed mesh back into UE4 → result

Error, Could not import Maximo_Maria1.
Duplicate bone name found (‘Maximo_Maria1’). Each bone must have a unique name.
Error Multiple roots found

This has me stumped for some unknown reason, its probably something simple that I’m over thinking. I’ve tried renaming every bone (Or joint as its called in maya) yet same problem persists. Any ideas would be fantastic. Thanks in advance!

Try GeoDav’s answer here:

my guess is that you have exported the character and imported a modified version, the problem is that when you export a skel mesh from UE4 it adds an extra root bone (standard for fbx api) there’s a good chance that this “root” bone is named the same as the mesh, so you need to delete it before you export from your 3d program, the lowest bone name should be b_root , that is if you are using the Epic content

I also found this:

When exporting HeroTPP.fbx from Unreal, for some reason, a dummy node called HeroTPP is also added to the bones system when you open it in 3D Max. If you delete that HeroTPP dummy helper, everything works like a charm!

In Maya, rename skeletion. You can retarget to the original skeleton later.

Thank you man, had the same problem. Your answer was the solution. God bless you.

This is exactly the issue. I unparented and removed the added dummy node. after that it imports back into UE4 just fine using the old skeleton on import. thx! :slight_smile:

Please help - still struggling-
After exporting a skeletal mesh to Maya from UE, how do I unparent and remove dummy node without losing the skinning information?

Maya wont let me freeze or reset dummy transformation because of the skinning info?

Thanks in advance for any help

Ok - I think I got it:

In order to get rid of dummy node without losing skinning info:
my suggestion would be to dupicate and copy the skin weights over.

  1. duplicate your rig.
  2. freeze the transforms you need to freeze.
  3. duplicate the mesh.
  4. bind your duplicate mesh to the duplicate rig.
  5. select the original mesh and shift+select the duplicate mesh
  6. skin > edit smooth skin > copy skin wieghts [option box]
  7. in the copy skin weights window choose edit > reset
  8. click copy

how did you unparent and remove the dummy node? this is driving me nuts.

how do you unparent and remove? if I select the mesh and unparent , it disappears.

if I open the hypergraph it shows the skeleton, root is at top , but above it is “jacket” (which this is a skeletal mesh named jacket), also at the very bottom is another “jacket” below the whole skeleton. if I try to select the bottom “jacket” and delete , the mesh disappears. if I select the top “jacket” and delete , everything disappears.

did you figure it out lol?

i had this problem too and now i solved with your help.thank you

None of the previous answers worked for me. Here was my solution:

-The parent group includes transforms which need to be matched

-Unparent breaks transforms on the mesh. It needs to have the same transform as the parent group. Do this by RMB-ing the rotate X>Unlock selected

-Re-lock the same property/transform by RMB (the transform)>lock selected

-Select the root bone, then the mesh>export the .fbx

330297-unreal-skm-reimport-04.png

*If there are any edits to the mesh, make sure to run edit>delete all by type>non-deformer history (before exporting)