Download

How to i Smooth models imported from Sketchup ?

How to i Smooth models imported from Sketchup ? i already tried auto smooth, mesh smooth, nothing work maybe because my mesh is all made by triangulates idk
2c6ff0712f409b0dc48cf0375de552fe2550494c.jpeg

Make sure that all the vertices are welded together, it’s possible that each polygon is separated on the imported mesh.

How i check that ? i dont have much experience on 3ds max i just use to UVs

Convert the mesh to Editable Poly, then select vertex mode. Select all of the vertices and then hit the Weld button. Once thats done, apply another smooth modifier.

Lower the weld threshold before you click weld though, default is 0.1 so if vertices are closer than that they’ll get welded together. I usually use a value of 0.001

Alternately, you can go to the Element sub-object level and then click a polygon, it should select all of the welded polygons, if they aren’t welded then it would just select the single polygon.

It works thanks but i still get some hard edges
8ec7364fb54ba0bc847998ef506e61da343dfa3a.jpeg

Any tips to make it smooth better ? i used auto smooth at 30 threshold if i put 90 threshold it start to deformation alot

The Smooth modifier only controls smoothing groups–it’s a render effect that makes surfaces appear to be smooth but doesn’t actually change the geometry in any way.
To add more segments on the curve there’s other things you’d need to do. In your case, there’s an issue that the mesh is triangulated. If you can, look through your export options from Sketchup or the import options in 3ds Max and see if there’s a way to import the model without triangulating the mesh. Otherwise, there’s a Quadify tool in the 3ds Max modeling tools that can try to automatically convert triangles to quads. There can be some cases though that makes it difficult to do that since it’s an automatic method, but on that curve it should work properly.
The other option is to manually select and remove the edges to convert them to quads, use the Remove button in Editable Poly rather than selecting and using Delete which will actually delete the edge and the polygons.
After getting the mesh to where it’s made of quads, you can do a few things–one is to select the Rings of each segment of the curve and use the Flow Connect tool, this will add a new loop that tries to follow the curve of the surface rather than just adding a loop in the middle. The other option is to apply a Turbosmooth modifier and check the box in the options to Smooth by Smoothing Groups. Smoothing groups are a number assigned to each surface that determines which ones get smoothed together. Using that option in Turbosmooth will make sure that you keep the corners but the smoothed parts will end up curved and more subdivided.

Ultimately though, you’ll want to spend some time learning more about how to use the software, some of this you might not understand. Make sure you know what a loop and what a ring is.

Looks hard but i gonna try Darth, thanks, i really need learn how to make those triangles change for what i want because even on sketchup it was triangulated and i think i gonna face alot problems like that so i need learn that sooner or later

Have you tried smoothing it in Sketchup instead? Right click -> soften/smooth edges

It adds more polys, but you could subdivide the spaces to manually smooth the edges without relying too much on auto-smoothing.

or maybe you fix this in sketchup first before you export it:
http://sketchucation.com/pluginstore?pln=RoundCorner