Download

How to hide 'FPS counter' in PIE mode?

Hi all, not sure where the right place might be for this.

Basically, I am using a friend’s level he built, and he has the ‘fps counter’ and other stats in the top right corner while in play mode. I want to remove them so they don’t appear in sequence recordings. He can’t remember how he made them appear, and I can’t find anything about getting rid of them, only the possibility of making them appear via blueprints, hence my posting in this neck of the woods.

Hoping someone could help.

Thanks!

Hello,

There is some ways to do this.

The first one in in the upper left corner of the viewport

Capture.PNG

And there is the possibility of doing it via console commands:

  • stat fps
  • stat unit

Also, if you need to remove the ‘‘Lighting need to be rebuilt’’ message, you can do it with this command:

  • DisableAllScreenMessages

(There is an ‘‘Execute Console Command’’ blueprint node.)

Hi, thanks for your reply!

I have tried that, but to no avail. I found that my friend made a HUD widget. I deleted that. I deleted an FPS counter from the level blueprint. I unchecked all boxes that mention FPS. I’m not sure, but I think it’s solely the sequence recorder. When I play in viewport and record, there’s no HUD, but when I render the capture and play it back, there it is in the corner. I can’t find anything in the sequence recorder settings that might de-activate this. There was one ‘display HUD’ option but it’s already un-checked. I did something and even more stats appeared under FPS.

Also, when I type ‘stat’ into console command box, nothing comes up as an option. Not sure why that is :\

Apparently, I might have this issue: Unreal Engine Issues and Bug Tracker (UE-52772) , but I can’t find a fix.

Hopefully this makes sense.

Thanks again for your reply.

On second glance, maybe it isn’t an FPS stat issue, but a system performance stat display. Still, I can’t really find how to remove it from sequence recordings.

All those things on the screenshot are from this command:

stat unit

Just write it, not all console commands are visible in the suggestions (Don’t know why)

Well ****** me, I think it worked this time!

I’ll do another recording and see if it stayed. Thanks!

Edit: I didn’t even know that as a sensitive word.

It’s gone! Thanks!

Hide all with ‘stat none

4 Likes