Download

How to get rid of "No Precomputed Visibility" warning?

I’ve checked precomputed visibility in world settings, placed Precomputed Visibility Volume in world, build everything 7 times, flew inside volume and still there’s warning about No Precomputed Visibility
If I enable Visualize Precomputed Visibility Cells I can see actual cells, so it seems ok, but the warning puzzles me
How can I check if it’s actually work?

You can disable the warning in the Project Settings under the Rendering section.

To test precomputed visibility you’ll need to do a few things. When working in the view port, switch to the Game View (press G) and make sure that the camera is within the visibility cells. Open the stats (reference the page link below) and move in and out of the cell or around the level and you should be able to see how well visibility culling is working. You’ll also want to use the FreezeRendering command (see the Visibility and Occlusion Culling page) if you’re unsure how well it’s working. When using this command, the rendering state of actors from that camera position are paused and you can freely move around the level to check how well culling is working.

Ultimately, you’ll need to just use game view and stats to get the overall results of how well precomputed visibility is working for your level. Keep in mind, that from the World Settings, you can also see how aggressive Precomputed Visibility is. By default, it’s not super aggressive with culling, so you may not get a lot of culling. Setting it to be very aggressive can cause additional “popping” of Actor visibility, so be aware of that too.

Anyway, I hope this helps!

Thank you for answer!
What are you mean “make sure the camera is within the cells”? In Visibility Cells visualizer I can see that cells are only near meshes, so for example if character jumps he’ll no longer be inside the cells. Is it ok?

Take a look at the doc I linked above. For Precomputed Visibility to work, the camera (whether it’s the one used while working in the viewport or the one attached to your player must be within that cell. If it’s not, there is no culling with Precomputed Visibility.

The character being in or out of the cell doesn’t matter. The camera position does. You need to adjust the playareaheight in this case. That’s covered in the link as well.

**r.PrecomputedVisibilityWarning 0 **(that will get rid of the warning, but won’t fix not having precomputed visibility).

1 Like