Download

How to get more precise collisions for a 3d platformer game?

Hello everyone, I have been working on a 3d platfromer game and this is something that has been bugging me for a while.
Sin título.png

While the radius for the capsule collision looks good for not overlaping with walls or other actors, it lets you walk well into the air before falling off a ledge.
Recently I tried solving this by checking with a raycast if there is floor directly below the players center, only when its not faling, and if there is none, then set the player movement to falling and the capsule to no collision for a moment so it falls. It works fine when walking off a ledge but not when jumping over a platform and landing in a point where there is no floor below the center of the player but the capsule collision is still over the floor, then it sets the movement to falling but lands anyway and looks weird.

Maybe theres an already known solution for this issue on 3d platforming games that I dont know about? I tried googling but all the results I got are about other issues concerning precise collisions or skeletal mesh collisions.

change PerchRadiusThreshold and/or ‘Use Flat Base for Floor Checks’

I’d also like to know the answer to this, and @Gmi’s suggestion isn’t working for me.

ue4_sergio_ledge_float.png

I have Use Flat Base for Floor Checks turned on, and my Perch Radius Threshold (and Ledge Check Threshold) are set to 50. I’ve tried smaller and higher numbers, and different combinations of those three options. But my little duder is still floating half a foot off the ledge.

@Cinebeast
https://youtube.com/watch?v=ruTokxc20p0
This does nothing for you? How large is your collision capsule?

Thanks, I set the perch radius to 200 and its working good for me.