Download

How to get around scale bug, when doing a simple animation FBX export from Blender?

Here’s what’s happening

  1. I export an FBX file from Blender (un-check leaf bones)
  2. Import in Unreal
  3. My mesh is the correct size
  4. My animation is not

I’m using metric.

I have read and tried a lot of the tricks of people who similar issues.
Scale it up to 100, then scale down etc… But whenever I export even the most simple mesh+animation I still have the scale error.

I think I am still missing something, potentially very obvious.

I’ve attached my Blender file as that will hopefully help. Any suggestions very much appreciated!

Here’s my fbx file too.

You’re not using metric 0.01 though which is what you need. Also you’ve got unapplied transforms on your mesh.

To fix it set the unit scale to 0.01. Then:

  • Select the rig and scale by 100.
  • Do Apply Object Transform, selecting scale.
  • Select the mesh and do Apply Object Transform, selecting location, rotation and scale.

That’s it.

Edit: Also having dots in your bone names will mess up reimporting. You should rename them to bone_001 and so on (or just a better name in general).

Hi @cyaoeu ,

Thanks so much! I think the mistake I kept making is not using unit scale 0.01, but object scale 0.01.
Very silly. I get normal and expected results now.

I’ll look into creating a script for this to make exporting a bit smoother.

You can just set the correct scene unit scale (metric 0.01) and then save that as a startup .blend file and you’ll always have the correct settings.

You shouldn’t need any special scale settings when exporting (just 1 scale like usual), but if you’re talking about export scripts I guess that can be a good idea.

The other workaround that fixed it for me was to simply rename “Armature” to something else! then you won’t need to mess up with scale units and etc.

Just recently had the same problem with my blender file and I managed to work it out by simply selecting the animation sequence files in the engine and by double clicking i went to their properties and set the import scale to 100 and pressed re-import and it was all good after that.

Thanks a million, pk85! Your solution worked easily and quickly :smiley:

pk85 I have been stressing over this for days. I know this is an old post, but you helped me out a lot today. Thank you!

1 Like