How to get Ambient Audio Actor to synchronize/continue playing in Background?

Hello Everyone,

At the moment I am adding sound to my scene. The scene is a queue line so I have several Ambient Sound Actors to play ambient noises, and several Ambient Sound Actors to play queue-line music to simulate in 3D the audio system a queue-line would have. In the documentation it is stated that:

“If the Ambient Sound Actor is set to Auto Activate, it will immediately begin to play once it is created (at the beginning of play or on spawn), even if the player is not in a position to hear it.”

However, the music only starts to play at its very beginning once entering the audio boundary. When leaving it, the music stops, once entering again, the music starts to play at its start again. The problem with several of these actors is, that they start to overlap, not syncing up at all which is what I would expect after reading the docs. With most of the ambient noises it’s not such a problem, for the music however it’s problematic. These are my settings in the scene:

These are my Audio settings:

it did not fit in the picture but important to note is that “Auto Activation” is checked ON.

Any tips/suggestions/hints are welcome, I would like to know what I’m doing wrong :slight_smile:

Best Regards,


Have a look at this question and Matthew Griffin answers, I think it’s what you’re looking for.

Exactly what I was looking for, didn’t find it in my forum and google searches but it does exactly what I needed. Thanks!