How to fully setup UE4 to work with VS2017?

The 4.14 version provides Visual Studio ‘15’ preview support, but now visual studio is called Visual Studio 2017, and when i use the native support from UE4 and press Open Visual Studio Project it still opens in VS2015. Is there any way to make it use the 2017 version when opening from the file menu?

No U can only use 2015 for now …
Earlier versions had 2013

I think the previous answer is incorrect.

I would say that you can actually use any IDE for UE4 Development as soon as you use the Visual Studio 2015 toolchain. So you should be able to use VS2017 for coding purpose. You just want to make sure that you have the vc140 toolchain installed on your computer (by installing VS2015).

It can be interesting to have your feedback about it so don’t hesitate to post it here (if you go for it) as an answer or edit :smiley:

Good luck.
Best regards.

That’s totally okay. I mean you don’t need this “Open Visual Studio” from the editor feature at all. Just open your .sln with Visual Studio 2017 as you would do for any project and work from there.

If your question is about “How to fully setup UE4 to work with VS2017” then you should rewrite the title :slight_smile:

I tried to activate the Visual Studio ‘15’ option inside unreal but it still doesn’t recognize the IDE , when i go to Open Visual Studio it opens the 2015 version and not the ‘15’/2017

Thanks Joris, i’ll change the title to better serve this question.

read this

Not being mentioned in the documentation doesn’t mean that you can’t do things, not at all.
The documentation is here to orient people in the most common tasks. If you want to do something more specific (like using Visual Studio 2017), you have to figure it out yourself, with help of the community !

You meant 4.4 with vs2015 right ? :smiley:

No worry at all :stuck_out_tongue:

that is true but i had faced issues when i had tried to use vs 2017 with 4.4 …
don’t ask why use old version :)?

Sorry if I sounded rude at all Joris Vial

Yes that is the case… I had run into this doc an that is why suggested the answer and nothing else . Yes of course it is possible what U suggest .

Try generating visual studio files from file explorer (right click on uproject file) and then it shoud open vs2017 by default from within the editor.

Dude… xD

Edit>Editor Preferences>General>Source Code>Accessor

This worked for me however I also had to “Refresh Visual Studio Project” as my files were originally created in Visual Studio 2015.

I installed 14Toolchain and nothing changed.
My case is VS2017 works but from Unreal editor it always open VS2015 as its default choice(I changed Edit>Editor Preferences>General>Source Code>Accessor as well).
So VS2017 is working and it needs to open yourself, it looks like it is a bug?

How did you do the “Refresh Visual Studio Project” bit?

File>Refresh Visual Studio Project in the editor