How to force montage to play from start?

When I call for a montage to play (from the start), it seems to was to play from the last frame and quickly loop back to the start.

The first time I play the montage it is fine, but every other time it starts with a pop which looks like it’s trying to play the last frame first.

Is there any way to solve this or to force the montage to play from the start?

I am using root motion,

Hi Trippy,

Can you provide more information about your project. What version of the engine are you working in? Is the montage an epic asset or one you created yourself? What is the animation of? Why are you using root motion? etc. As much information as you can provide will help us in isolating the problem.

Thanks

Hi Steve,

It is a ledge climbing animation. So Hanging from ledge to standing above the ledge. This is not an Epic animation but I am using the Epic standard Mannequin character.

So if you look at the animation from the side while against the ledge I have the character offset slightly. The montage should translate the character directly upward before across to stand on the ledge. This is what happens first time, however every subsequent time I can see the character moving towards the cliff face, not translating directly upward as it should.

If I remove the cliff face entirely and play the animation the unexpected horizontal movement becomes even more apparent, popping way off mark as if it is playing the final frame of the montage then popping back to the start.

Input is disabled too so it shouldn’t be getting any stray movement info.

Hope this extra info helps.

EDIT: I am using version 4.6.1

Sorry it’s taken so long to respond. It sounds like the way you’re describing the animation is “in game.” Does the animation function properly when previewed in Persona?

Just to clarify, does the montage play correctly when previewing in Persona vs playing in the editor? -Or does it appear to loop from the last frame in Persona itself. (This was a bug in the past and has been fixed is why I’m asking.)

Hi Trippy,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue of the Montage not playing from the start, please respond to this message with additional information and we will offer further assistance.

Thanks

Hi Steve, sorry for the delayed response, I have been incredibly busy and haven’t had the chance to follow up on this project. From memory I do not believe the issue happened in Persona, only when playing the game.

Hi Trippy,

I have not been able to recreate this issue. Are you still experiencing this problem in the latest version of the engine? If so, would it be possible to supply the asset so we can take a closer look?

Let me know, thanks.

I have tested this in 4.7.1 and it is better but my animations occasionally do the same weird movement forward at the start of my ledge climb. There shouldn’t be any movement input as I have disables it while on a ledge. I may have to try not using montages now root motion from everything works better now.

Since you are having success without montages for the animation at the start of the ledge climb I would suggest not using them there. However, in other cases montages should work fine -If you experience any other issues with using montages let me know.

Thanks

I haven’t tried not using montages. It was something I thought I could possibly try. I don’t know if that is a solution yet.

Sorry, I thought you meant root motion is working correctly now and you did not need to use montages for what you were doing. Please update when you’ve tried not using montages.
-Thanks