How to fix UE4 4.19 not compiling shaders? (Getting stuck at 45%)

I’ve been having some very strange issues with 4.19 that I can’t seem to resolve, issues which weren’t present when I was using 4.18.3; namely, attempting to launch a project with additional rendering features (for example, enabling Clear Coat Dual Normals, or enabling Mesh Distance Fields) results in the editor getting stuck initializing at 45%. I was running into this issue in the 4.19 previews, preview 3 and preview 6 specifically that I tried… and I’ve tried looking at every possible solution out there.

I have tried deleting the Binaries, Intermediate and Saved folders in my project folder. I deleted the engine version folder at: %userprofile%\AppData\Local\UnrealEngine\

I tried creating a new project without starter content- which works fine until I enable either of those project features and then it gets stuck.

I’ve tried waiting 45 mins + for the project to compile shaders- but I’ve opened the task manager and noticed that no shader compiler tasks get launched. I’ve also noticed reinstalling 4.18.3 that the first time I launch the engine I do get shader compiler processes launched and even in the editor browser screen I see the little pop up in the bottom right alerting me to how many shaders are still being compiled.

I have tried a full and clean installation of Windows 10, same issue. I have tried enabling and disabling my antivirus and firewall. I have tried updating my graphics drivers and rolling back my graphics drivers… nothing seems to work.

As far as I can tell, on my system 4.19 is getting stuck enabling extra rendering features which it is expecting to recompile shaders for but for whatever reason cannot launch the shader compiler.

None of this makes sense, and on my system a totally empty project should not take more than a few seconds to load. For the record I’m running on an i7-7700k with 32GB of RAM and a GTX 1080ti with the engine installed on an SSD.

I want to be able to use 4.19 for the improved Temporal AA features, for the unified AR features, and especially for the ability to import SpeedTree 8 models from their beta modeler for UE4. While it seems I am to some extent able to use 4.19 as long as I don’t touch anything in regards to the project settings… being unable to use features such as DFAO and clearcoat normals as I can do in 4.18.3 is a huge setback.

Try to launch it without admin, there is the problem that you launch only the engine as admin not the shadowcompiler, thats something that i noticed when i tryed to launch a Project directly and had Admin checked inside the properties of the Engine.exe. Noticed this problem with the engine verion 4.18.2.

At least you can use the 4.19. i couldnt get the 4.19 to run. It always hangs up at 45% when the engine is initializing (waited for 8 hours and it dosnt worked, tryed a new clean build didnt helped, followed many topics, tryed a rebuild of the Shadowcompiler).

How do you enable or disable admin for the program? All I’ve done is install the engine and launch from the Epic Games launcher- I’m not running as admin from the executable.

For anyone coming to this thread at a later date, I found a solution in my case!

For me, the solution was uninstalling a third-party development tool called “IncrediBuild”.

This was a tool included in one of Visual Studio’s coding packages who’s background service interfered with proper operation of Unreal Engine.

I was able to track this issue down with help from the members on the discord server when attempting to build a version of the engine from GitHub source and the build kept failing as a result of IncrediBuild. Whatever benefits this service purports to offer, my current suggestion if you encounter a similar error in your UE4 install is to remove this tool from your system.

exactly , thats what happened for me.

thanks for sharing this, your solution worked for me.

I don’t have IncrediBuild installed and it still stuck at 45% when I load Product Viewer template. The old projects it opens but not compiling shaders. I have the same error with UE 4.20. What else can I try?

if its stuck and ur cpu is 100% , then give it time to finish compiling .

since UE 4.20 is still in preview , you cant confirm yet, wait for final release. bec I’ve the same issue with 4.20 preview with some projects.

CPU is staying at 20% and I have let it run for 3 hours, my system is (i7 6700HQ, 16Gb RAM, PV 1070 GTX, laptop). I have also delete DerivedDataCache.
Can someone provide me a link with Product Viewer template UE 4.19 already compiled?
Thank you.

try to find incredibuild under software on windows. sometimes you think you havent installed increadibuild but it is on your system without noticing it.

here is a way to disable Increadibuild manually so that Unreal Engine UBT isnt searching for it:

same but has a little bit more information about disabling increadibuild:

It is the same with me but this will be bad If I try to create mobile games as the tool wasn’t having this issue in previous releases of Unreal Engine!!!

This answer made me so happy :)…totally worked for me - the whole project runs 10X faster even…THANK YOU!!!

IncrediBuild is required for you to be able to build games for mobile devices, so if you don’t want to build games for mobile devices then you can uninstall it, there are two reasons for the issue you are facing:
1-the texture or materials that you are using doesn’t work on mobile.
2-the IncrediBuild service is off, just run it from windows services and everything will get fine.

I don’t have IncreadiBuild installed and is still stuck at 45%.

Hi all,

Just for posterity, I never saw this posted & we had the issue with a 4.20.3 project we were working in/with, turning off shader compile via config.ini stopped one of our guys from hanging every time the editor tried to compile them:

r.XGEShaderCompile = 0

That’s in ConsoleVariables.ini.
Hope it helps some!

-Matt

For a project related configuration just place into /config/DefaultEngine.ini:

[SystemSettings]
r.XGEShaderCompile = 0

That looks good too :wink:

Confirmed for me (UE 4.22). Was stuck on 50% saving a material, couldn’t compile shaders. Turned out I’ve installed a Visual Studio package, as described. Removing from “Add and Remove Programs” menu worked like a charm.

Thank you, man! Couldn’t find the problem for a week. Only after delete any links to IncrediBuild from Windows Registry shaders compile begin.