How to fix the errorr:OodleDecode: compressed buffer starts with zero byte; invalid or corrupt compressed stream.

As the picture shows, “OodleDataCompression: Error: OodleDecode: compressed buffer starts with zero byte; invalid or corrupt compressed stream.” error always shows in the console.
How to fix it?

hi have you solved this problem?

Hello! I just dealt with this today. For me this ended up being related to the Derived Data Cache. In the end, I ended up just deleting the whole thing and that fixed it. I have no idea if that will work for you, but it’s worth a try!

Hi, I have found a solution for this:

my situation was, that this error message was showing and it results in corrupted nanite meshes - distorted - similar to proxy meshes.
Occasionally there was another error related to Derived Data Cache.

I tried to delete DerivatedDataCache from project (as well with Binaries, Intermediate and Saved) and rebuild the project, but with no working outcome - error was still spamming the output log.

But there are other DerivatedDataCache - not for project, but for editor installation itself. My was at C:\Users<user>\AppData\Local\UnrealEngine (Note: AppData may be hidden)
I deleted this folder and this fixed issue. Side effect is, that you will loose all your editor settings like, window layout, projects in launcher view, etc…

1 Like

The error has been solved! Thank you so much!

Hi there,
Tried all of these methods and no luck for me. Deleting the DDC, rebuilding, all of it - I’m still getting loads of this error trying to update my 5.1 to 5.2 Any further solutions?

Hi, there.
Well, my was UE5.1. The error was solved because I deleted C:\Users\<UserName>\AppData\Local\UnrealEngine\5.1\DerivedDataCache folder and project DDC. The Engine itself also has DDC in the installation path. My was D:\Program Files\Epic Games\UE_5.1\Engine\DerivedDataCache. But I forgot whether I deleted the folder or not. Maybe It’s worth to try to delete all of cache folder such as Saved, Intermediate, DerivedDataCache etc.
Hoping it helps for you

I was getting this error after a 5.3.2 (source) packaging attempt caused my computer to bluescreen. I originally thought it was something corrupted in my project files but after I tried to open a fresh project and got the same error I realized it was a problem with the engine (or Windows 11?).

The following steps might be overkill but they did end up resolving the problem:

  1. Delete the Derived Data Cache (DDC) in my source compiled Engine
  2. Delete DDC in AppData (C:\Users\AppData\Local\UnrealEngine)
  3. Delete DDC + Binaries, Intermediate, Saved from project folder
  4. Turn off “Read-Only” on all subfolders of engine and project
  5. Restart PC
  6. Open Engine solution in IDE and compile
  7. Right-click on Project file and “Generate VS Project Files”
  8. Open Project solution in IDE and compile
  9. Launch project into UE Editor and observe error being resolved
1 Like

I’m experiencing the same annoying error spam and unfortunately the steps from @Regentlord above did not help. This happens only in a specific project in which I opened the Unreal Learning Kit with UE 5.3.2.