How to fix imported bone transform is different from original?

I use blender 2.72 and when i export my character in UE 4 all is fine but with animation i get this error and some bones are not where they should be. I dont know what to do. I was searching the internet in last 2 days and i did not fixed it. Please help!


If it is a transform problem then push ā€œNā€ in blender to bring up your transform menu. There you can see Location/Rotation/Scale and Dimension. Note that if your scale is not 1 on the XYZ axis you will get a transform error. Same goes for rotation which I try to keep 0. If it is different select both your Skeleton and your mesh push CTRL+A and select APPLY- ROTATION&SCALE.

Sometimes your mesh scale is 1.2 and your skeleton is 1(just an example) then you get an error. Are you using a custom character with your own animation or are you trying to modify unreal animations/character?

Plus update to Blender 2.75a they have improved FBX exporting tremendously.

1 Like

Thank you so much. I fixed it just by updating it. Btw i use my charater from makehuman with animations which i make in blender.

One thing to try as well for easy animations for the current UE4 skeleton is UE4 TOOLS addon for blender. Great way to easily create animations for existing characters in Unreal Engine 4.

Thanks. I will give it a try

This is what saved me!

I had to export from blender in ASCII version of fbx.

That is the worst you could do. File should be in binary, otherwise you going to have a lot of problems in the future.