How to fix double clicking to select an object in the UI

I’ve recently run into a slight complication. Before, I only had to click once, to select an object, in the UI, to move or edit it. Now, for some reason, I have to double click the object, and click it again, just to select the object, and get the axis point to come up. I’m not exactly sure if this is a bug, some key that I may have accidentally hit, or something else. I know that it’s not a MAJOR issue, but it is definitely an inconvenience, when you’re used to working a certain way.
Thank you in advance.

Did you already tried to change your OS to run applications on one click? Don’t know if it will work but it’s worth try i guess? If you’re using Windows 7 or up go to: “Control Panel/Appearance and Personalization/Folder Options” There you should see the options to change Windows to double-click or single-click

If you have any gamepads plugged into your machine check that their analog sticks are not providing the editor with input. Sometimes a loose analog will report slight input. This input makes the viewport think it is in flight control mode and disables selecting actors with a single click. I’ve also run into this issue when using StreamVR. Simply closing StreamVR and re-running it and the UE4Editor fixed the issue for me.

1 Like

Thank you both for your answers. @anonymous_user_f4997b28 was right. It was my gamepad that was causing the error. Everything is back to normal now. Thank you both again.

jesus christ i would have never in a hundred years thought my ■■■■ gamepad could control the editor.

thank you very much!