How to fix: Could not find code error

I just downloaded unreal engine on to 2 of my machines. I wanted to try out writing a plugin so I found a live stream video where the programmer shows the widget reflector. When I click a code file it says “failed to find code file: whateverdirectoryishere.” The directory is nonsense and is pointing to a thumb drive. I have this exact issue on both computers. I tried reinstalling on one machine and it did nothing. I can navigate the source code manually inside visual studio but the widget reflector is linking somewhere else.

How can I change the directory the widget reflector is looking for the source code in?

1 Like

Hello Rhombuster,

Did you download your engine from the Epic Games Launcher or did you download the source code from Github and build it? Does this happen with every code file you try to click on? What widget did you select? Can you provide a screenshot of this occurring?


I downloaded the engine from the launcher. I installed the editor to the C drive. I already had visual studio 2015 installed.

I can open cpp files from the content browser (like example project files). But every link inside the widget reflector is broken. This exact thing is happening on 2 separate machines that downloaded independently. They both ask to access D drive.

Originally I thought it was because my project file was on a flash drive. But I uninstalled, wiped project files, cleared AppData of anything unreal related. Uninstalled the unreal launcher. Downloaded all of it again. The exact same issue has come up.

I run into the same problem and I think this function only works if you had build the engine from source because the path you get is the same I get and it seems to be the original build path the engine was built at Epic and its somehow hardwired into the code.

It is annoying that you even can’t copy the path and I found no other solution to this then to remember the file name and manually open it.

Good catch, SteffM. It seems the reason it works in Binary for me is due to it actually accessing the file from my source build. As this is a developer tool, I wouldn’t expect full functionality from it in a Binary build so I would suggest using a Source build if you need to use this.

Updating this with a summary of steps to solve it:

  1. You need to create a symbolic link from the D Drive back to the C Drive.
  2. Install Editor Debugger Symbols.

The Symbolic Link is paramount. Unreal Engine by default is looking in the wrong drive.
You can get more info and images here: