How to fix broken blueprint ?

I used enums for map keys.

When I tried to add an element to it, I got the error “The element cannot be added because there is no default value.”

I may have quit the editor forcibly last time. Currently there is a bug now.

Currently, I can’t open the blueprint containing “Map with enumerations in key”.

If I try to open it, the editor will be killed forcibly.

Blueprints that do not use it can be opened without problems.

If the editor encounters an error opening the blueprint, can’t it skip reading that node ?

It’s terrifying that all the “Blueprint node trees” I’ve created so far are engulfed and rendered worthless by the single wrong node.

Have you tried replacing the broken Enum or Blueprint with a backup from Saved -> Backup folder?

Dear Nicat.

Thank you for your response.

I found out the existence of that folder.

I can avoid “editor crashing” by replacing broken BP with renamed old one.

But…this means rolling back to the closest historical data, doesn’t it ?

In other words, if I don’t have a backup, there’s no way to recover from it.

It would be the same that I can avoid problem by duplicating the project frequently.

Though, thank you for your knowledge of backup folders.

I hope for a future revision of the editor so that it will not save object if it has an error.