How to fix broken blueprint pins, that "no longer exist"?

Hello,
I have a blueprint from C++ class that many times refers to some other C++ class. So, I have made some changes to the referred class and now the blueprint throws a compile error on every reference, saying

"In use pin [name] no longer exists on node [get …]. Please refresh node or break links to remove pin."

343015-ue-bp-err.png

VS Expected (and how it previously was):

343016-ue-expect.png

I tried to restart and recompile, but that didn’t help. Since there is a lot of stuff in the blueprint, I’d prefer not to generate a new one, or manually replacing every single reference.

Is there a way I can fix it automatically, or less painfully?

Note:
The C++ class is still the same, same name, referred functions still exist, everything should work fine as is.

1 Like

Right click on variable then click refresh node. This should solve it. You can also find refresh all nodes under file. This will not reconnect the pins but will remove any erroneous pins.

Hey, thanks for the response, since it’s C++ variable, not blueprint variable, I’m not sure how to refresh it. I have also tried the refresh all nodes, but it does nothing.

343051-ue-no-vars.png

Any workarounds yet? When I open my project through Unreal Engine 5 itself it can’t see my enum structure written in a c++ class. But when I “start on local machine” in VS2019, it launches UE5 then opens my Project and it works fine… I don’t wanna launch my project through VS because it makes UE5 crash a lot.