How to find UnrealBuildTool for ARM Linux compilation

Hi everyone, I am actually tring to build a little game on UE4 that would run on a raspberry pi 3. I was told I need to compile for a ARM Linux, and I’ve followed the tutorial on EU4 website. I’ve packaged my game and tried to run it on the Pi but I get the error : Cannot execute binary file: Exec format error. After looking to the tutorial again I noticed this part

" If you are using the Linux-ARM cross compile toolchain before running GenerateProjectFiles.bat below edit the following file in the UE4 source code:
by commenting out the following line:
static private string DefaultArchitecture = “x86_64-unknown-linux-gnu”;
and un-commenting the linux-arm architecture line just below it:
//static private string DefaultArchitecture = “arm-unknown-linux-gnueabihf”; "

That would probably be the reason of this error, because the compilation is not for ARM. However I can’t find the files I need to modify. I follow the same path, but when I click on program, I only get UnreamHeaderTool instead of UnrealBuildTool. Any idea of how I could find the file I need to modify ? Maybe it is somewhere else ? Thanks for the help

UBT should be in the given path otherwise you would not be able to compile the project. You can see it in the github repository: .

Thanks for the answer, I tried looking for it with your link on GitHub however the link seems to be broken, or maybe I’m doing something wrong but the page can’t be found. and about the given paths you can see what I get on my picture.

The page is part of the Epic Games repo on Github and you will need to make sure you have linked your Unreal Engine account and Github accounts to access the page. The steps on how to link the two accounts can be found here:

You don’t seem to have your github account set up to access the repo - how did you get the source? Maybe UBT sources aren’t distributed in binary only build…