How to Enable Input on multiple instances

I have a door Blueprint, which when I’m near to it pressing ‘E’ opens it.
It works fine with one door, when there are multiple doors, only the last added one detects the input, the rest of the doors doesn’t listen to the input.

On the Blueprint event where ‘E’ is pressed uncheck the consume input box.

Solved it from here

A Docs reference:
Look for “Consume Input”

It’s always helpful to read the whole documentation :smiley: