How to enable gas-static mesh collision?

I watched this awesome video:

In the video, the author sets up a Niagara system from a template, and then uses the actor tag ‘collider’ to make a static mesh (sphere) interact with the fluid simulation. It works quite well.

However, if I make my Niagara system start out empty, and then manually add the gas emitter, the ‘collider’ tag no longer has any effect. Is there something in the gas emitter (or its Niagara system) end of things that I have to add, in order to get collisions working?

Thanks for your time.

Hey @sjhalayka!

Yup! It’s these right here:

These are user parameters that look for the tag to make it collide. You can also add your own tags, or have it specify components that have a tag. For instance, if you wanted characters to interact with the fluid, you’d ONLY put a tag on the character’s skeletal mesh and add the tag here :slight_smile:

To create one, click the + and select “Niagara Data Interface Rigid Mesh Collision”, then just add your desired tag/s!


Thanks for your quick reply!

I tried to add it, but there is still no collision:

It’s got to be something really simple. :frowning:

From here, it’s likely we’re going to need more data. What are you using to test with? Does it have a rigidbody? Try testing what you’re using with the template gas fluid emitter. If it doesn’t collide with THAT smoke we know the testing actor is an issue.

Also I’d go ahead and add the other Niagara Data Interface collision (the geometry one)

Can you possibly give us more screenshots? A video would actually be REALLY helpful! :slight_smile:

1 Like

OK, here is a video of me trying to get colliders working:

1 Like

P.S. any chance that I can have my video size cap upped? I think it’s like 25MB, which is only like 15 seconds worth of video.

Dear @Mind-Brain, I was missing a key step: I had to set the “baffin” actor to movable in the actor’s mobility setting.

With the plasma gun:

With the lightning / Brownian gun:

1 Like