How to do shadows for translucent materials?

Hey guys

for a living room scene I’ve made curtains and windows and my problem is: the window casts shadows, but the curtains don’t.

The material I’ve made for the curtains is translucent and I think the problem has to be in the material settings, but I can’t find it.
So does anyone know how to do shadows for translucent materials?

Hey @Jvv_00!

You should be able to enable shadows for your translucent objects using a shadow pass switch node! You can learn more about setting those up in this non-Epic affiliated tutorial:

I hope the above is the solution you need!


@Quetzalcodename Thank you so much! Will check that out

Hey @Jvv_00!

Checking in! Did the above solution work for you?

@Quetzalcodename Thank you! I had a problem with my light sources, because they didn’t work for a few weeks (now I have the solution) and at first it did not work out.

But now, since everything works again, your answer was the solution to my material question! :slight_smile: