How to Disable the Input for the AI

Let’s make this quick and painless becuase this is bothering me alot since an hour i’ve been looking everywhere for this on the Internet.
I want to Disable the input put a delay and enable it again so that the Ai doesn’t do ANYTHING while that countdown of the Delay exists. Just like i did with my Player but it won’t work with the Ai for what ever reason. How do i do that?
Please help me…