How to disable speed decreasing?

I was making a game about space, so I want spacecraft there to have absolutely no speed decrease when there is no acceleration.
I set the movement mode to “flying”, and set the speed decreasing factor to 0. But the speed decreasing is still there no no forces are applied. So I wonder what did I miss?

It would be better to enable Simulate Physics for the spacecraft mesh and use thrusters or add force for movement for that kind of thing. I’ll release this project in a couple of weeks for free if you want to wait for it.