How to disable spawning of default CameraActor from CameraManager?

For the love of god I can’t figure this out.
Still kind of new to Unreal Scene.
I am using Unreal Engine 5, but I don’t think that’s relevant to the problem because I believe I have this issue on UE 4 as well.

I’ve done the following:
-Created my own Game Mode and set it as default.
-Created my own Player Controller and set it as default in the Game Mode.
-Create my own Camera Manager and set it as default in my Player Controller.
-I am spawning my own camera class in blueprint inside of the Camera Manager and setting it as blend target.

After all of this, my game is still spawning a CameraActor by default that is owned by my Custom CameraManager.
I can’t find a setting to disable this or a function to override this.

How do I get rid of this useless default camera that I don’t want because it’s out of my control?

1 Like

It’s obviously there for some sort of reason, and it’s not doing any harm, so why remove it?

I’ve read many threads on this, and there is no sane way of preventing its spawning.

1 Like

Dang.

The OCD person in me wants me to remove it. It’s like a got a clean work table and there’s a piece of gum stuck to it that I can’t get rid of. The unknown of why it’s there also slightly annoys me.

I also figured optimal-wise (though I guess it’s probably very minimal). There would be a way to remove unnecessary actors like this camera.

Thanks for the response either way.

2 Likes

On my case I have already a camera that I am setting as main view target on the level blueprint. I have to pass this project to the client and I don’t want him to be asking me why there are 2 cameras when he press play so I need to prevent this camera from spawnning

as usual after posting a question, I answer myself with the solution a little bit later. This is how I finally prevented UE4 to generate a new camera


On project settings , setting the default pawn class to none and having the rest to none or new classes

This does not work for me.
I made new empty Gamestate, PlayerState, Spectator, Playerctonroller, GameInstance, and set my HUD and PlayerPawn to None. And I still get that strange CameraActor spawned in that is not the main camera.

I got rid of it by running this on begin play:

2 Likes