How to disable permanent message on screen

300467-untitled.jpg

hi, im wondering if anyone can help me here. trying to get rid of two messages on the game screen.
“profiling with AI logging on!” and “profiling with GC verify on!”
i have no idea how they got enabled, some key shortcut in the editor for a node somewhere, or a checkbox, accidental console command, i dont know.
ive done a google search for the messages printed on the screen to find out how to get rid of them, and was sent to pages related to UDK/UE3 going on about console commands gameprofile start and gameprofile stop, neither console commands existed in ue4 btw.
im sure its a simple fix for those who are in the know with the console command names.
i started looking for editor reset option but didnt succeed there.
does anyone know how to disable this message? or even reset console back to normal? or tell me a pref folder to delete somewhere? that’d be fantastic, im feeling pretty stupid right now but hey, its a forum so…

It’s on because you have already run a console command, probably something with ‘stat’ on the beginning. It’s warning you that you can’t realistically profile a game in ‘play in editor’ mode.

Also, if you look closely, in feint text underneath the message it says you can use the command:

disableallscreenmessages

to get rid of them… :slight_smile:

yes i did enable netprofile with console commands at some point, was to see how structs behaved in network replication, and viewing generated *.nprof files later.
that one in particular works without the red writing so i just wondered what caused it exactly.

BTW if anyone else comes across this message and cant get rid of it, embarrassingly, i found the solution - restart the editor :expressionless: there you go, no problem, no messages :slight_smile: