Download

How to Disable Griffin Dive?

I’m working on a mod which alters every flyer to have proper speed loss and gain based on angle of flight, energy put in, etc, and it’s working great on my Argentavis, Wyverns, and Pteranodons… but the current Griffin Diving mechanic completely messes up my changes. Does anyone know how to disable the Griffin’s Dive?

Found a solution, deleting certain graphs related to the management of Diving in the Griffin’s parent blueprint removed the diving feature. I recommend duplicating Dino_Character_BP_DivingFlyer to wherever your mod is and setting Griffin_Character_BP to be parented to the new copy instead of the original. Some animations get messed up in the process though, so some tinkering with the AnimBlueprint is also required.