How to disable "Fast Path"?

Hello, I was working on a project and encountered a problem, so I was doing a small test. The screen shot is from that.
The problem is that “Fast path is enabled” on animation bp.
I checked:

but I am not proficient enough to understand the document.
It seems not many people asking same question.

There are few, but I don’t get the answer either…

Thank you in advance!

Ever get an answer to this?

I am having the same issue. Can somebody help, please?

FastPath is good. It basically means your animation blueprint will run faster than normal, by using multithreading. You don’t need to worry about the specifics if you do not care about performance at the moment.

A quick summary is basically this: If one node in the ABP does not support fast path, your whole blueprint will be slower. It is automatically disabled if any node does not fulfill the requirements. If you want to make sure you have fast path fully enabled, try to pre-calculate all necessary variables in the event graph (or in code) and use only raw floats and bools in the animation blueprint.

1 Like

Thank you for the answer. My enemy character didn’t switch to run animation from walk when his max walk speed was switching from 150 to 600. I thought FastPath was causing that. Then in ABP’s Event Graph I set the speed variable from the character’s max walk speed instead of velocity, and it worked for me.