Download

How to disable default UMG keyboard controls?

I have a menu system set up that uses keyboard, gamepad, and mouse controls to select various options. Everything works fine except when using the gamepad which from my understanding emulates the keyboard’s arrow keys (left, right, up, down) which also behave incorrectly. This causes the keyboard focus to jump over the next item instead of moving in line.

Edit
To be more specific, I’m trying to modify or turn off the default UMG controls or navigation. In other words, if I disable my custom stuff, I can still use the keyboard to select buttons in the widget. So that means something in the background is handling that. And I want that to not happen. Thanks

Edit2:
On one of my menus, I have an pointer icon that rotates and points at each menu item. If using my code below, it works fine for WASD. When using the arrow keys or the D-pad on the controller, the pointer doesn’t rotate. Yes I have those keys and D-pad buttons in the same action event for WASD but they’re being handled by something else in the background.

Example:
Start focus is menu item 1. If pressing right, it should go to item 2, then 3, etc. But instead it goes from 1 to 3. If I use WASD or the gamepad analog sticks, it behaves correctly.

Now I assume the issue that I have it so when a menu item is selected, it enlarges and when deselected it shrinks. My guess is the default system is moving based on size and position of the focused item rather than the next item in the array as everything else does.

My code:

Player controller:

Widget:

Hello, did you find a way to modify Widget Navigation setting? I have a similar problem. I want to modify the navigation settings to merge with my virtual navigation system.