How to disable Blendspace/StateMachine or Locomotion?

So after my character dies, plays a death animation montage, the blendspace goes back to the idle animation.

How can i prevent that? Or how can i disable the Blendspace/StateMachine or Locomotion? Thanks.

1 Like

Hi,

You can add a loop to the death animation montage (preferrably towards the end) so that it keeps looping until you do a reset. This would make sure that the death montage is still overriding the blendspace/state machine source for the montage slot.
The reset would include :

  • Stopping the death montage (You can use the call Montage_Stop in the Animation blueprint)
  • Resetting all the variables of the character : Position, Health etc

regards,

That looks like the intended behavior, just to be clear what behavior do you want to achieve ?

Hmm, the moment i stop the montage, the blendspace takes over, even when there is a delay or i destroy movement component.

Call Montage_Pause, not ‘stop’. From my call to “Montage Play” I attached the Return value to a Delay node, and the delay node to “Montage_Pause”. Worked like a charm.

Thanks. This here seems to work 70% … sometimes it goes back to idle.

Okay, if you add in Deactivate Mesh, then followed by a Delay, it works.

Found another variant: you just could untick the option in Animation Montage - Enable Auto Blend Out.