Download

How to delete timelines

Hi,

I have done some tests with Timelines in one of my blueprints, Timelines that I don’t use anymore. But for some reason I can’t delete them from the Variables panel.

Capture.PNG

When I right click on them, the Delete option is greyed out. Hitting delete on my keyboard just offers to rename them.

Is that a bug or is there a specific rule I don’t know about?

Thank you

If you can see the component name there, then the timeline node is till in you graph. That’s where you delete it.

Thanks for the reply. That’s weird though, when I try to find the references, it does not show me anything. I even placed an extra one just to test, and even for that one I can’t find references.

Yes, same here, you just have to look for the node :slight_smile:

Right, I ended up finding them, thanks!

Still not sure why “find references” does not work on these, but thanks for the help!

It does find them, as long you manually write them down.

1.jpg

Yes, I meant finding references like with variables. It shows the getters and setters in a log and then by double-clicking on these it takes me to where they are in the graph.

Thanks EvilCleric, this works, also couldn’t find the timeline via Find References option, and Delete grayed out.

This was the error, removing/adding new float curve fixed it.


LogBlueprint: Warning: Timeline Timeline1 Track Time in /Engine/Transient.REINST_CombatCharacter_C_2034 has an invalid curve.  Please fix!