How to Default Fullscreen in Shipping Package

We are using 4.7 version of the engine.

We are having difficulty getting a shipping package to default to fullscreen upon starting. We are stuck with a window version of it, and even upon fullscreen, the taskbar and window frame are still visible. How do we fix this?

Thanks!

The answer should lie in your DefaultGameUserSettings.ini file. Inside “your project”\Config create a DefaultGameUserSettings.ini file. Inside that file, put the code below. Be careful that there are no spaces in front of each line.

[/Script/Engine.GameUserSettings]
bUseVSync=False
//ResolutionSizeX=1920
//ResolutionSizeY=1080
//LastUserConfirmedResolutionSizeX=1920
//LastUserConfirmedResolutionSizeY=1080
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=True
FullscreenMode=0
LastConfirmedFullscreenMode=0
Version=5

This should default to fullscreen, using the native desktop resolution.

Note, that the double slashes are comments, and you can also set a custom resolution by uncommenting those lines, and setting bUseDesktopResolutionForFullscreen=False.

There are multiple fullscreen modes:

0 sets the game to true fullscreen.

1 sets the game to windowed fullscreen.

2 sets the game to windowed mode.

Also, for some reason when launching a standalone game from the editor, it completely seems to ignore the resolution values and just sets the resolution to some default. The packaged game should still use the correct resolution however.

Thank you! Works now

Hi, do you know why Version=5 is added?

Thank you for your answer but do you know how to make the intro movie in fullscreen because mine is fullscreen but windows taskbar overlap

To be honest, I don’t know what you mean by “intro movie”.

In 4.10 when I make a packaged game, I don’t see a DefaultGameUserSettings.ini file anywhere. I did a search for this file but nothing comes up.

Same here, is there new way to fullscreen?

You create your own file inside the folder.

Thanks it worked.

He means ‘Startup Movies.’ See Project Settings < Movies in the editor.

I did that, but the game still starts in windowed mode. Where did I go wrong??

Same for me

This is also breaking for me, since going to 4.13 packaged games only go to windowed mode. It was previously going to fullscreen 4.12 and before.

4.13 not work

how can I set fullscreen in 4.13 shipping package

I solved this by delete the Saved\Cooked\WindowsNoEditor\widget3d\Saved\Config\WindowsNoEditor\GameUserSettings.ini file

and update the file
Saved\Config\WindowsNoEditor\GameUserSettings.ini

[/Script/Engine.GameUserSettings]
bUseVSync=True
//ResolutionSizeX=800
//ResolutionSizeY=600
//LastUserConfirmedResolutionSizeX=800
//LastUserConfirmedResolutionSizeY=600
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=True
FullscreenMode=0
LastConfirmedFullscreenMode=0
Version=5

This script works for me in everything up to 4.13 (so far)

Create a DefaultGameUserSettings.ini in your config folder and copy / paste the below script into it.

[ScalabilityGroups]
sg.ResolutionQuality=100
sg.ViewDistanceQuality=3
sg.AntiAliasingQuality=3
sg.ShadowQuality=3
sg.PostProcessQuality=3
sg.TextureQuality=3
sg.EffectsQuality=3

[/Script/Engine.GameUserSettings]
bUseVSync=False
ResolutionSizeX=1920
ResolutionSizeY=1080
LastUserConfirmedResolutionSizeX=1600
LastUserConfirmedResolutionSizeY=900
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=True
FullscreenMode=0
LastConfirmedFullscreenMode=0
Version=5

GameUserSettings