Download

How to create new Blueprint child class asset without C++?

I want to create Blueprint assets (from a world outliner selection) and I’m trying to figure out the “Create Asset” node, but I can’t even get it to accept any path:

No matter what I do, it always complains about either a leading / or a trailing /…

(Also, I cannot find any documentation or examples using “factory”, but I’m crossing my fingers that this is optional if you want to create one of your own classes…)

I am not using C++ so please, please only reply with a blueprint solution! (Someone told me of a way to pop up a folder selection dialog in conjunction with this node, but unfortunately it was a C++ solution.)

Is it not complaining about path not starting with a valid root instead?

try with “/Game/” in package path. /Game/ is your project content folder.

Thanks, but both /Game/ and /Game gives the exact same error message.

There’s several nodes that look as if they would provide a correctly formatted Path as well, but they don’t, and under Editor Utilities, I don’t see any node that fits…

Can you check what you put in asset name? You could even force it temporary to something like “TestAssetName”

Maybe your get display name give you string with a “/” at the end or some weird character.

Thanks again!

Turns out, the asset name I was inputting was an empty string, causing that error message because I was using the “Get Selection Set” node from the Editor category when I was probably supposed to use “Get Selected Level Actors” from the “Level Utility” category (not to be confused by the “Get Selected Actors” node from the “Scouting” category) and similarly, I was supposed to use “Get Attached Parent Actor” instead of “Get Parent Actor”…

However, what is even more confusing is that even if I skip attempting to get the display name of something from my world outliner selection and just input a static name, I get the following popup:

So, ok… apparently an asset was created… but where is it? I can’t see it, I can’t search for it and I can’d find it even in Windows Explorer…

And honestly, the whole thing about game/content is so confusing to a beginner. The folder is called Content in Windows. When you migrate an asset to a different project, you need to select the Content folder. Why, in some cases, is it called Game? :confounded:

On Exit, I got this:

Why does it say “Empty Package”? Do I need a “factory” for even my own classes? If so, how do I create one?

But regardless, I chose to save it and still I can’t find it. It did not end up anywhere, neither in the project or Windows Explorer.

Sigh… a friendly soul told me that what I apparently really wanted to do is to create a new child class, and that can only be done with the following C++:

And similarly, my plan to get the editor to pop up/show some form of folder selection can apparently also only be done in C++:

So, leaving the above answers for those who use C++, but I apparently have to continue to do cumbersome stuff manually if I want to stick to Blueprint only. :frowning:

I’ve just worked around this by using the Duplicate Asset node instead. It’s not ideal as you need to keep a blank object around to actually duplicate, but it’s better than nothing if you need a Blueprint only solution.