Download

How to Cope with Broken Undo?

The Undo feature in the Blueprint editor viewport is broken. I’m talking about the window where I visually design the objects which make up my game, which is a huge part of game dev workflow. When I drag something around then hit undo, my selection is cleared, which means I have to reselect the object again. If I change a component value on the right side, and hit undo, it simply doesn’t work, until I manually deselect whatever I’m editing in the viewport, and then hit undo again, and then reselect the thing I was editing. If I close the Blueprint editor without saving, open up the Blueprint again, and continue editing, the undo history becomes corrupt, and the viewport has a chance of becoming desynced such that it no longer reflects the values shown on the right.

This is a serious question: How do you make games in spite of this? I do not understand. Is there something I’m missing? I keep coming back to Unreal with every new version to find these bugs still present. I want to use Unreal… I really, really do! I’ve filed a bug report, but the bug fixing process is so opaque I have no idea when/if it will be fixed. I am surprised these bugs are there in the first place, but I’m even more surprised that nobody seems to talk about them. How are games being made when the window used to design objects doesn’t allow you to undo properly? Am I just the only one who uses undo?

I apologize if this sounds sarcastic or ranty, because it’s neither. I am seriously curious as to how people manage to get things done with these bugs present. Thanks!

I’ve never seen (or heard of) this bug - which engine revisions are you seeing this in?

If you believe you have found a bug with the engine, please report it to the Bug Reports section of the UE4 Answerhub](https://answers.unrealengine.com/spaces/11/bugs-and-crashes.html). Our support staff will follow up with you there as we investigate the issue. When submitting a bug report, please be sure to include all necessary information to assist our staff in reproducing the issue, such as engine version, reproduction steps, hardware and OS information, screenshots, and anything else that may be of value. Thanks!

@ambershee I am using revision 4.12.5, but this has been around since I first tried Unreal 4, a year ago. [MENTION=9]Stephen Ellis[/MENTION], I did submit a bug report. It has been confirmed reproducible, but there is no word on when this will be fixed.

I can totally wait if I have to. I’m just very bewildered that nobody else has seen this, since it is 100% reliably reproducible. Just start a new project, make a new Blueprint, make a sphere or something in the Blueprint. Then move the sphere and hit undo. The sphere will now be deselected. If you manually type in a new position and hit undo, it will either: 1) deselect the sphere and require two undos to work, or 2) simply fail.

I have been using the engine since before it was released publicly and never have experienced this bug. I tried to reproduce what you said but i cannot(the manual pos one). Maybe someone else will be able to get it to be reproduced.

Edit: After messing around after awhile. I have always experienced a deselection of something in the viewport when undoing. Even in other applications, not just ue4. I thought this was expected and intended behavior because you’ve selected and moved the object. Undoing only undoes the last actions. Selecting an object isnt an action. Moving it however is. Since selecting isnt an action, It doesn’t remember you selected the object therefore deselecting it. I believe applications like 3dsmax do think of selection and deselection as actions but it looks like unreal, and many other things do not. I have a feeling it is working as intended, although i have not looked at the source.

@SaxonRah, it actually happens for subsequent operations too.
For example, if I select, move, move again, hit undo… it will undo only the last move operation, but also clear the selection.
In fact, if I manually type in the new location instead of dragging, undoing will only clear the selection without putting the sphere back! :open_mouth:
Therefore the bug is not due to Selections being disregarded as actions.
Here’s a video which shows many of the bugs I described:

https://www.youtube.com/watch?v=InV5-TGTZQ8

The bugs in the beginning of the video happen all the time.
The bugs later on in the video happen about half the time.
I’ve tried this on 3 different computers, all with the same result.

(Sorry for the bad video quality, I could’ve sworn I uploaded 720p, but it was only 480p)