How to configure logging in packaged build?

To configure logging in ordinal cooked build you specify required log level in [ProjectName]/Config/DefaultEngine.ini, [Core.Log] section.

There’s no such file in packaged build.

If the file doesn’t exist yet, you can create it:
[ProjectName]/Saved/Config/[ConfigurationName]/Engine.ini

Where [ConfigurationName] is WindowsNoEditor, for example.

You can add a [Core.Log] section then.

After you run the game the first time the file shows up as well.

Unfortunately, this doesn’t work. There was file [ProjectName]/Saved/Config/WindowsNoEditor/Engine.ini and I added [Core.Log] section into it (there already were another sections like [WindowsApplication.Accessibility]), but it makes no differences.

Have you tried this? You can find additional information on this documentation page.

[Core.Log]
global=[default verbosity for things not listed later]
[cat]=[level]
foo=verbose break

Yes I did, I added

[Core.Log]
[MyCategory]=Error

to suppress log spam but it didn’t help. I tried adding this to Engine.init and DefaultEngine.ini in all places I could imagine (creating these files if they didn’t exist). As I said it works fine in the project folder with cooked content. It doesn’t in packaged build.

Andy,

Thank you for providing me with this information. I am still looking into this and you’ll be contacted once we have additional information. I wanted to give you a status update so you knew I hadn’t forgotten about you. :slight_smile:

Hey Andy_T,

That is the correct section, let me walk you through what I would do if I wanted to add verbose logging for online testing with IOS.

  1. Open Game/Config/DefaultEngine.ini or Game/Config/IOS/IOSEngine.ini
  2. Find or Add the [Core.Log] Section
  3. Add LogOnline=Verbose

Both of these files are used when packaging, for IOS. Please do not use the Saved/*.ini file that is mentioned above. This isnt the right place and has no effect in a packaged build.

If it isnt working, there are a couple of things I would check. The log string identifier is correct and full. I.e. LogOnline.
I would also check that the log you are expecting to see has less of a priority than the verbosity you are displaying.

/Terence

I put DefaultEngine.ini in both Game/Config/ and Game/Config/WindowsNoEditor folders. This didn’t work. Did you try this yourself?

Hi Andy_T,

Yes, we use this ini option to help us debug. Are you saying that you didnt have a DefaultEngine.ini file inside your Game/Config folder originally. The defaultengine.ini file is usually a dependency and should create an error when that file does not exist.

Also, for windows no editor specific options, you want to add a Game/Config/Windows/WindowsEngine.ini file. Note that it is in a “Windows folder” and it’s named WindowsEngine.ini, not DefaultEngine.ini.

You can also have a look inside Game\Intermediate\Config\CoalescedSourceConfigs\Engine.ini and see what is listed under Core.Log. This should allow you to see what the Windows Editor has for it’s values, which is usually what the Windows No Editor Game will also use.

/Terence

Package/[Game]/Config originally (after packaging) contained only our custom ini-files, nothing like DefaultEngine.ini.

Package/[Game]/Saved/Config/WindowsNoEditor contains

Compat.ini
DeviceProfiles.ini
EditorPerProjectUserSettings.ini
Engine.ini
Game.ini
GameUserSettings.ini
Input.ini
Lightmass.ini
Scalability.ini

but modifying Engine.ini has no effect. So why it’s there?

Saved/…/Engine.ini files contain only deltas and runtime settings made by a user or code

Are you trying to make these changes in your Packaged game? Cos they need to be made in your actual games folder, then repackaged.

yes, I do this in my packaged build. Repackaging takes ages. So each time I want to change log level or another config option I need to repackage and redeploy 6GB? Why the engine doesn’t simply read a config file from package? It does read it from pak file but since it’s not possible to change why not to read it from an ordinal DefaultEngine.ini file?

Andy,

In order to make changes, you’d need to edit the log information in your actual game folder and then repackage the game.

Thanks.