How to configure Adreno Profiler to work with UE4.15?


Don’t know why Adreno Profiler doesn’t want to work correctly.

How I setup it.

First, I registered at Qualcomm’s site, then downloaded and installed Adreno Profiler software.

Second, in Android device(mine is Sony Z1c, Snap 800) in Developer’s Settings set GPU profiler to “adb shell dumpsys gfxinfo”.

Third, in UE4 Project Settings → Android → Graphics Debugger selected Adreno Profiler.

Fourth, added location of ADB in system’s “Path” variable - ADB that I downloaded through “CodeWorksforAndroid-1R5”

In Adreno Profiler when I click connect I get “No Adreno Profiler-enabled app.” The same, if I open AProfiler after deploying app to device


And if I use “stat GPU” in console I get


I’m getting this too.

I added the manifest permissions specified in the profiler help docs…

(though maybe the Unreal project setting Project Settings → Android → Graphics Debugger does this anyway)

I also ran this before profiling “adb.exe shell setprop debug.egl.profiler 1” as specified in the Adreno Profiler help.

Is your project a mobile VR project? I saw some posts on the Gear VR forums that Adreno profiler doesn’t work in VR mode… which would be unfortunate since my project is using cardboard.

OK I got it working using the side scroller starter content. I’m using a Note 3 so Snapdragon 800 Adreno 330.

Here’s what I did - based off a google translate of this forum post :stuck_out_tongue:

There’s possibly a couple of superfluous steps here but this is everything i did…

  • I set the profiler in Unreal Project Settings → Android → Graphics Debugger to “Adreno”
  • Added the manifest lines in Unreal Project Settings → Android → Advanced APKpackaging
  • “android.permission.INTERNET”
  • “com.qti.permission.PROFILER”
  • Launch on Device in Unreal
  • Once it’s built and running… Close app on device
  • Restart phone… (don’t know if this helps)
  • kill adb.exe process in Windows (The profiler needs to initialize adb apparently)
  • Open Adreno profiler
  • Click “Connect…”
  • In windows open a cmd prompt window and run “adb.exe shell setprop debug.egl.profiler 1”
  • Run app on your phone…
  • Hit refresh in connect window and it was there and I could connect and use the profiler.
  • Sometimes it takes a few seconds for the game to appear in the list… I usually have to hit refresh 3 or 4 times.

(BTW - In the phone’s Developer options I did not have the app set as a debug app and Profile GPU Rendering was set to Hide - Those are things that people have said need to be on but they weren’t set on my phone.)

This also got it working for my Cardboard VR project. Yay :slight_smile:

EDIT: Ok so I think the main problem is you just have to hit refresh in the connect window a couple of times before the app will pop up. I have since done this with a build running from Unreal and it works fine. Though I’m finding the profiler crashes a lot which is annoying.

So I tried to do it again before using your recommendations, and “voila!”. It works! I just launched AProfiler and game on my phone.
That’s strange!
I think, the game must be restarted after deploying, then launch AProfiler

But now it give birth to new questions, how to use AProfiler :stuck_out_tongue: .
Green strokes in UE4’s debugger more informative than these graphs

Anyway, I set your answer as right. Thanks!

These might help… but yeah there’s a lot to look at.

Also… with the crashes i was getting - it seems you can just ignore them and keep going.

Hello, I just also get crashed when capture frame using AProfiler, But It’s ok in UE4.14.3. link text
It’s weird!

First you must check your device is connected using adb devices.
Second in Adreno Profiler’s FAQ, you can use adb.exe shell setprop debug.egl.profiler <1 to enable, 0 to disable> to enable debug mode.

Then It’ll be works!