How to change the unsupported format of .uproject file to supported format?

Hi All

I’ve recently formatted my PC, I’m having a problem in my project file. Recently I pulled the ue4 4.9 source code from my office perforce P4V server along with that I took my working project which is under ue4 4.9. The problem is .uproject file in the project folder is not showing the blue U icon it is showing as an unsupported format can anyone please tell me how to change it to blue U icon because of this problem I cannot able to create visual studio files and my work is paused for now please help me with this issue otherwise I cannot able to go further.


Install the engine from the launcher or run setup.bat

Hi I’ve tried installing the engine from the launcher it is not working need to try the setup.bat method

Still uproject is not showing in blue U icon. I tried reinstalling the ue4 and then I tried to associate by double clicking on Engine->Binaries->Win64->UnrealEngine-VersionSelector-Win64.exe still .uproject file is not showing in blue U icon.