How to change the output of a variable from float to boolean?

So I was following the tutorial about how to make our character jump and I was stuck in the point where he connected the time remaining ratio with the float-float variable and the last one was connected to the result, which is a boolean. The thing is that when I tried to do it (and at this moment allow me to underline the fact that I didn’t know anything Blueprint until yesterday), I noticed that the output of this variable is float and from what I tried to do, I couldn’t change it to boolean.

Is there a way to do it?

Thank you in advance!

If i understood correctly you need to compare the float and get the result of that comparison as a bool. If so, drag from your float variable and then type <,> or = and you’ll get the compare function you need depending on what you want to use the bool for.

That makes no sense. You’re trying to convert a decimal point value into a true/false value. There isn’t an implicit conversion for that.

I think what you’re missing is some sort of comparison node in the tutorial. Go back and see if there’s a node you missed which looks like “<=” or “>=” or “==”. That would compare two float values and give you a boolean value.

Thank you Slayemin for you answer. If you have a minute, check this tutorial that I am attaching. At 08:00 is the point that I am having the problem. Maybe the problem is that I am working on 4.9 and this is a tutorial for 4.8. The thing is that when I am doing the same thing, the output is not boolean but it’s float.

Thank you!

I verified that the tutorial video you sent is valid in 4.9.1. It’s good.

I think the problem may be on your end. Can you take a screenshot of the transition node you’re having trouble with and post it?

Hi, Im having the same problem in that same tutorial, exactly at 8:25. Where the “float-float” node conects to the “can enter transition” bolean receptor. So on my float-float node I do not have a bolean (red end) and cannot make the conection…

It is not float-float; it’s float ‘less than’ float. You need to search for “float <” in the context menu.

Thank you - I was having the same issue. When I searched “Float<” found the right one and the connection worked great! The tutorial did state Float-Float. ( I think that is what got confusing) Anyways- Thank you -thank you-thank you. :slight_smile:

Sorry it did say less than. Time to take a break lol