How to change the color of dynamic shadows?


Is there a way to change the color of dynamic shadows? The world’s ambient color is ignored and the shadows are black.

And is it normal that the mobile preview doesn’t display dynamic shadows?

I believe dynamic shadows are not supported on Android with UE4

On 4.5 we support one directional movable light; to get indirect (so not full black), you need to add a skylight.

Btw: There is no “color of shadows,” there is only “color of light.” When a particular light is absent, the color of that light is removed from the surface that’s shadowed.
This might seem obvious or redundant, but it’s really, really, important to actually always understand and think like this, or you will be led astray in your lighting setup.
When the world has an “ambient color,” that’s really shorthand for “color of ambient (assumed to always be present) light.”
RCaloca suggested how to get ambient lighting into the scene – add a skylight. This adds a light that’s not explicitly direction/shadow-dependent like a directional or spot light.

Thank you guys for your answers! I added a skylight to my scene and my shadows are not pure black anymore :slight_smile: Now I can tint their color in the postprocessing volume.

There’s another issue: I still can’t see my dynamic shadows on the landscape. They are shown on my device but not in the mobile preview. Is it a bug or did I miss some settings?

I’ve heard that people are not seeing landscape shadows (they are supposed to work AFAIK), so I’ll ping the dev responsible.

Landscape shadows now work on mobile preview, as of changelist 2347659, I’m hoping it’ll get into 4.6!