How to change standalone game quality settings?

Hi all,

I am currently trying to find out if there is a way to alter the quality settings when launching a standalone game window. The current project I am working on seems to use “Epic” Scalability settings when in the editor window, but then switches everything it can to as low a setting as it possibly can if I launch in a standalone window.

I’ve tried the console commands below connected to an “EventBeginPlay” Node, but apart form the fullscreen command none of them actually appear to work for me. If anyone has any ideas your help would be much appreciated.

77740-console_commands.png

Can’t advice anything helpful actually, but I think that easier way to test console commands is to print them exactly to console in application itself (usually console opens by pressing ‘`’ key)

That didn’t work either. None of the settings appear to do anything in my standalone game window. They work fine in editor and in the pop up editor window.

EDIT: Looking at it further it appears to be the fullscreen command that causes the issue. If I just resize the “Standalone Game” window to almost fullscreen the quality remains good, but if I use the fullscreen command in the console everything starts to look quite blurry and poor quality.

You can modify your config file to set the default settings for your game when it launches. Check Saved->Config->Windows for your config files. Mine are inside GameUserSettings.ini

we use R.SetRes {rez} sets the resolution You could try adding windowed-fullscreen to it

That partially helps me. It turns out the game window doesn’t use the correct resolution when going fullscreen.The line below:

bUseDesktopResolutionForFullscreen=True

was originally set to False - changing it makes no difference to the standalone game window, but I now have two “Execute Console Commands” in my level blueprint, r.SetRes 1920x1080 and fullscreen. This gives me a fullscreen with the correct resolution, but is only fine as long as I don’t change to a lower resolution screen. I don’t suppose you know if there is a command I can use to set resolution to the same as desktop resolution when in fullscreen?

I could also do with knowing why my GameUserSettings appears to do nothing if you have any ideas.