How to change character position in Animation

I imported animation from Maximo and position of character in animation moved to a strange pose. Root bone is in right position, but pelvis moved so the animation looks not as it should be. How can I change it? Not changing skeleton for all animation or not recording a new one.

Did you retarget that animation into that character? in that case in the upper left of the skeleton tree there’s an options tab, click on that and activate retargeting options, and set everything on skeleton except for the pelvis and root who need to be on animation or animation scaled.

If that’s not the case maybe the animation has root motion, so just activate it on asset details > root motion > enable root motion if the animation has root motion it would get it to floor level.

If it isn’t either of those you can apply an additive correction to the pelvis bone, just select the pelvis bone (preferably on the first frame) and move it to your desired position and/or rotation, and click the add key (white + symbol at the top of the animation) and hit apply then save your animation and the pelvis should be on the position you set as an additive.

Hope it solved your problem :slight_smile: if not, with more info, like what it should look like, or the method you’re using to import/retarget the animation I may be able to help you more.

1 Like