Download

How to blend attack animation to idle state?

After setting up my state machine and the slots for the attack animation. The attack montage lerps perfectly to each animation, but how do I make the montage lerp to the idle animation for a smooth transition? Would I have to create an animation that transitions to the exact beginning of the idle one or can I lerp between the two?
Anim Blueprint below…
The montage uses the Upperbody slot.

No file was uploaded it seems.
Would need to see that to understand what you mean.

Generally. The idle animation would resume from where it left off, so its not a guarantee that making a specific animation that lerps to frame 0 would blend correctly.
(It would still blend more correctly than other stuff though).

I see what you mean. I added an animation that ends at the idle starting frame, but the idle frame left off at some other frame and it pops back. There has to be an easy way to lerp to the idle animation

Try changing the time on the blend poses by bool node.

Aside ftom that, now that the image is up, I don’t see anything that would directly cause that sort of a problem with your setup.

Could you film the issue happening as well as the way that the montage is set up and being played?

I just uploaded a video on youtube of the issue

There’s multiple noticeable issues.

I think that, at a base level, the issue is the montage itself.

It needs to transition back all the way to something that at least resembles the idle stance.
From then on, the blend values should be enough to prevent stutters.

And let’s not go into overcomplicated setups.
You could fix it by what we can refer to as “black magic” but it will cost you time.
Just adjusting the animations is usually less than an hour’s work, making complicated setups just overcomplicated junk… if you can make animations…

1 Like

I thought about that after posting the video abd changed the animation to go back to an idle pose, but it still pops back to the idle frame instantly with no blending or transition

In which case, we need to see how you call the montage.
It has options for blending when you call it from code.
It could be these aren’t set right.

The montage is being called by blueprint with a “Play Montage” node.

You must be right, because the idle and walk animations are blending perfectly and not used in a montage, so it must be the montage itself

I found the issue. Naively I thought the montage would blend with the state machine, because the state machine blended together. It seems all I had to do is redo my animations last frames to end at the first frame of the idle animation. Thanks for the help!

1 Like