Download

how to avoid triggering a trigger with the spring arm + camera ???

I have a trigger and in the event handler (OnActorBegginOverlap) I dont know how to discriminate between the player pawn mesh and one other of the blueprint components, in particular the camera at the extreme of the spring arm.
How can this be accomplished? I want the trigger to be triggered only by the mesh, not the camera. Thanks.

Set up the collision channels on the trigger to include a channel that the player physics has, but the camera ray does not have.

where are found the trigger channels? in the details panel when the volume is selected there is no channels settings.
Thanks.

It’s in Project Settings under Collision

In your project settings, you can go to “Collision” and create a new “ObjectChannel”.

http://puu.sh/ldKYo/7564c7c6e4.png

Hitting new channel, you can give it a name (like Trigger or Player, depends on how you wanna do this) and a default
response, which is blocking, overlapping or ignoring. Depending on how you want to use this, you may chose “ignoring”
and then go to the Collision Settings of the Blueprints you want to react to this, or other way round, you select Block or Overlap
and go to the ones that should ignore the Channel and change it. That depends on which way is more work. If you only want 2
actors to overlap with that channel, you use Ignore for the default response.

Then in the Blueprints, you can go to the Collisions that interact with one another and change the settings:

If you set “Collision Presets” to custom, you can change the Object Type to your new one and select how it should react to
this object type. On my screen there are only the default ones, but if you create a new one and recompile the blueprint, you will see
the new ObjectType being added to the list.

thanks, Im going to try (although I still have doubts…)
I think trigger volumes by default should ignore cameras or spring-arm “probes”

Edit: after thinking and trying it, I think I still dont get it… you see I need the spring arm do the collision test, without it it does not serves to me as I need…
I created a new channel that I called “SpringArm” with Default Response “Ignore”

now what’s the next step?, I have player pawn that’s a blueprint with many components, one of them is a spring arm with a camera as child. That has set the “do collision test” on,
should I set the “probe channel” to the “SpringArm” channel I’v created?

EDIT2: … you’d want to kill me… :stuck_out_tongue: It was my bad, the defaults are set to triggers to ignore cameras in springarms, the problem was that as a child of the camera I had a Text Render objcet… with collision on.
Sorry for the inconveniences… :frowning: