Download

How to avoid inverted Normal maps

I used the same normal map I had previously made with Blender and used in Unity 3D too. But when I used it in UE4 the normal map got inverted: what was supposed to be concave now is convex.

5a9c4b44c0bbede1cb25c2bb05694672b7ee4b72.jpeg

Any ideas?

Thanks guys :slight_smile:

DPC

Open the texture file (double click it) and flip the green channel.

Your normal map is not imported correctly. When you import a normal map you need to make sure it is using normal map compression which you can check that the map is a normal map in the import options. You can also add to the file name “_normal” and it will import it automatically as a normal map.

Thanks Bruno Xavier.
So I guess this is a common practice in UE4 ?

For those newbies like me, and to remind myself in case I need to:
You achieve that by double-clicking the normal map texture, opening this way the Texture Editor. There under the Texture section, click on the little triangle/arrow pointing down to extend that section so you can see the “Flip Green Channel” checkmark. Click Save on the upper left corner, Done.

Also when you create your normal maps, just switch the green channel swizzle when you bake and you’ll never have to deal with it again =]

Thanks Xerithas :slight_smile: