Download

How to avoid Cloth generated artifacts when teleporting Skeletal Meshes? (using Level Sequencer)

Hi everybody, this is my first question here.

I’m having a bit of a problem with my Sequences. I have a Character with Skeletal Mesh and Clothing that I use as a Possessable Actor from the Level Sequencer to play various animations during my game. (For design reasons my Character cannot be spawned by the Level Sequencer)

The problem is that when the Possessable Actor gets possessed and translated immediately to great distances, the cloth management system results in some artifacts during the translation (wich is instant!).

Specifically, I see what seems to be like stretched meshes from the origin of the translation to the actual final position.

I know it is related to Cloth because if I deactivate it (set Disable Cloth Simulation) there are no wrong graphics displayed when I start my Sequence.

I would like to have my Cloth simulated during the sequence though! I tried re-activating Cloth Simulation AFTER starting the sequence (just using a Delay and setting to false Disable Cloth Simulation after Playing my sequence), but it seems that Cloth Simulation doesn’t get updated, so I have no way to turn on Cloth Simulation after my sequence started.

I also tried to play a bit with the “Force Cloth Next Update Teleport” and similar nodes but with no result!

I really want to have Cloth simulated during my Sequences… can you give me some insights on how this works?

Thank you

Sorry to bring this up again, but I couldn’t find any solution yet!
Nobody has some insights on the matter?