How to avoid camera clipping against the boss

Hi guys! I’m having this problem on my game. When the boss is too close to the player, the clipping appears. How can I fix that? Thank u!

From your clip, I’m assuming that you use a Spring Arm Component.

What happens is that it tests collision between your character and your camera. If there’s a collision (like a wall), then the camera is moved closer not to be inside the wall. In your case your boss is also considered in the collision test.

In you Spring Arm Component settings, you’ll notice that the collision channel is set to Camera.

So, in your boss collision setting, you’ll have to create a Collision preset that exclude the Camera channel (Ignore should be checked)

Oh I knew it! It had to be something like that. You save my so much time. Thank u man, big thank u!