How to attach a mesh to a socket with Blueprints?


I’m trying to make a jetpack pick-up my character can wear, but I can’t figure out how to attach the jetpack mesh to the character’s socket. I’ve tried and tried, but couldn’t get the jetpack attached using Blueprints.

Any help would definitely be appreciated!

I’ve made a simple workaround, I use the jetpack mesh as a component of the player character, hide it on game start, then when I need it I unhide it :slight_smile:

This should be fairly easy- is the jet pack it’s own blueprint? Could you maybe post a screenshot of what you were trying? I think AttachTo is the function you want.

Yes, the jetpack is its own Blueprint, but the only problem when I got it to attach as a static mesh was that it didn’t animate with my character. As a skeletal mesh it behaves as expected, but I’ve found my solution as stated in the comment above to be a bit better under the circumstances.

That sounds very odd- static mesh components and skeletal mesh components should both attach and animate in the same way. Were you specifying a bone name? Did it not move at all, or did it move with the character, but not with the bone? How did you create the backpack blueprint? Is it possible it’s ModifyFrequency is Static not Dynamic?

It did move with the character, it didn’t follow the character’s animation though.
The reason it did work ( I think ) with the skeletal mesh is that with those, you can feed it a skeleton + animation to use, which isn’t available in a static mesh.

The ModifyFrequency was indeed set to Dynamic, so other than that I really have no clue why it happened.

If you need to animate the jet pack, you’ll need that to be skeletalmesh. If staticmesh, it won’t animate. I think James thought it didn’t attach and animate with the character animation.

Adding as component is desired. You can attach actor to actor, but then you need to make sure to attach to “bone” of skeletalmeshcomponent of the character. By default character’s root component is capsule, not mesh.



You could get the jetpack attached using Blueprints like that

For me it works, and as a result I attached the hat to the character :slight_smile:


This is a question from the beta version of the engine. We are marking this answered for tracking purposes. If you are experiencing an issue similar to this please post a new question.

Thank you.