How to add simple flat background image to level?

Hi, I just need to add simple flat png or jpg background image for level background. No skybox, no scrolling, no lights over image, just simple light unaffected bitmap in the background of 3D objects. I tried it with widget but the image is over 3D objects. I can’t find a simple answer anywhere, also, there is an unanswered post about this…
How to use any image for level background? - Community & Industry Discussion - Epic Developer Community Forums background.html

1 Like

You can import a plane and give it a material that is emissive with 1 color. You can also use the geometry tools instead of the plane or enable the EngineContent, search for plane, make a duplicate and bring it into your own folders, but I still recommend importing a plane. <3

Thank you for a quick response. I did it that way before, but I used base color instead of emissive. I changed to emissive, now I can delete all the lights and background is not affected. But the main problem is that the image is smoothed, not as sharp as exported from photoshop. And you have to make a level start blueprint with camera, position player start etc… its a 3D object. There must be other way to add static background image in 2D space that looks exactly as should look, without smooting…

1st, if you are referring to an answer, make sure to hit the reply button to comment under my comment (it’s for other people, so they can see it’s the same context and not another solution to your problem).

But back to topic, you can use the Paper2D Plugin (which is enabled by default) and use [Sprites][1] for that.

If you decided for one of of those (plane or sprite), you still have to make sure to make some [changes in your texture file][2]. The lazy solution is to go to the settings
and change these settings; MipGenSettings: No Mipmaps, Texture Group: UserInterface2D, Never Stream: Checked, Filter: Bilinear
That should give you the same texture like in photoshop, even though you should check the other settings and decide depending on your case.

Also, if by any chance this is the solution to your problem, don’t forget to hit the resolve button, otherwise report back! <3

No luck yet. I’ve changed properties in texture file, tried both plane and sprite. When using plane, I tried to change material domain to user interface, but the texture remains brighter and less sharp.

What kind of game are you doing? You can also disable your post process, especially the tonemapper. That way you should get the same picture. If there is still a difference, please upload a screenshot so I can investigate further <3