How to add component to blueprint in 4.7

I’m using 4.7.6, and would like to add a component to a blueprint. All the documentation references a component window, with and add component button, but for the life of me I can’t find it.

How do I enable it?


This is in my Character


Hi, what version is that? I don’t have anything like that in the blueprint editor?


What version you running?

The Same! Maybe it’s because you have a character?

I’ve tried it on pawns and other bluprints based off them and I don’t have a Components tab anywhere!

Well, I don’t know what happened. I opened up a blank character and now I have the components tab.

I don’t know how that worked, but good on you!

There is no add component option when i created an actor class blueprint, what gives? Ive gotten the option before in other blueprints.

Also i checked my other blueprints and they dont show the components tab at all.

OMG okay so if you cant see your components tab it might be unchecked in “Windows” So go to “windows” tab at the top of the window and make sure its checked or it wont show up.

Hi CloudMonster,

did you check if you have the “Components” entry checked in your Windows menu?

Please see the screenshots enclosed.

First, there is no component window visible, I assume this is how it looks like for you:


Then, you check the “Components” entry in the Windows menu and it works:


Cheers, Mateun