how to add 64 bit native code library?

According to google’s new rule my android game’s must have 64 bit native code libraries. So how to add those in unreal engine? I tried checking arm64 to package the game but instead it gave me 2 separate apk one for arm7 which has no 64 code and arm64 which in not supported by 90% of android devices on earth because this 90% of android phones are arm7. I am no programmer and I am stuck. I don’t know what to do now and google will remove my games from playstore. If I upload my games as arm64 then all most all of my users will have to lose this games because it will no longer be supported in their phones. Somebody please help me with this, I am begging you.

Hi there.

The Google Play Console accepts multiple Android App Bundles for a single release. If you include an armv7 and arm64 .aab (android app bundle), Google will automatically give the user the content it needs, while maintaining 32- and 64-bit support.

To bundle your APK’s, follow this tutorial made by Onjigo Origins, it worked for me.

One more thing. Make sure the ‘Version Code’ (Project Settings > Android > Store Version) for your armv7 APK is lower than your arm64 APK. If it is not, any releasing will fail.

If you have any other question regarding this topic, I want to help!

Thank you very much, This worked for me.

I followed this video I couldn’t get it to work. It kept saying “merger error” during the signed bundle build.

Manifest merger failed : Attribute application@appComponentFactory value=( from [androidx.core:core:1.0.0] AndroidManifest.xml:22:18-86
is also present at [] AndroidManifest.xml:22:18-91 value=(
Suggestion: add ‘tools:replace=“android:appComponentFactory”’ to element at AndroidManifest.xml:3:3-43:17 to override.

I found one solution which was to add the below code to the but this caused even worse errors.

Any help?

Hi. It has been a while since I did all of this. I can not recall having this specific error.
Make sure you follow the tutorial exactly step-by-step, skipping something can cause your build to fail. I experienced that a lot.

I recommend trying to package an empty project before you adjust your main project.
If that empty project successfully works, compare its manifest files and such to your main project, and vice versa. This way, you can easily identify what the problem is.

Btw, if you are using any newer engine version, it might be the outdated tutorial. I haven’t tried this with projects above engine version 4.22.

Also, have you checked the follow-up to the tutorial? How To Bundle UE4 Project With Android Studio Update - YouTube
Make sure you perform all the required steps in this one too.