How to active DirectX 12?

Hi, I’m new to unreal Engine.

I have Unreal Engine 4.12.3 and have no Idea on how to go about activating DX12. I found options in what I remember to be in the File tab and only had the options for DX10 and 11. There are noYouTube videos for this and would probably be very useful to a lot of people if there happens to be a YouTuber out there who know how to do this. I found this but am unsure how to go about doing this.

Also, does it matter if you start you started making your game without activating DX12 first or not?

I am new here as well, just write to support you. I want to know as well. Thank you.

Create a shortcut of UE4Editor.exe and at Target add -dx12 at the end of line (after the “…” -dx12). You can also go to project settings, Target Hardware, Windows and uncheck DX10 and DX11 and it will automatically run on DX12. If this will break your stuff i don’t know, its just info from AnswerHub.

Edit: however, for me currently, DX12 takes 10-20 fps away on my 970GTX.

If you have to ask this question here, then you should not use DX12.

I had the same question and couldn’t find all the comprehensive information bundled at one place.

And so I decided to create this Video Tutorial & Blog Post.
How to activate Real Time Rendering with Unreal Engine (UE4) - DX 12 and Ray Tracing with Nvidia and the RTX Technology.

Please let me know if I forgot something to mention, or if I missed something important I should add.
I hope that will help everyone - super stoked & happy about Epic Games!

Happy Ray Tracing :slight_smile:

The shortcut method did not work for me but going into settings did the trick, Thank you

I disagree. With UE4.26 The atmospheric fog is crashing everytime I try and place it in my editor. Supposedly I’m running Vulkan, and it crashes when placing Atmospheric Fog.